Home | Site Map | Contact

Impatica for PowerPoint

Impatica for PowerPoint Downloads - Windows

Note to Impatica OnCue Users
Impatica OnCue 3.3 requires version 3.3 of Impatica for PowerPoint. Do not uninstall Impatica for PowerPoint 3.3 before installing Impatica for PowerPoint Version 5; the two versions may be installed on the same system.

Impatica for PowerPoint Version 5

Installer (.zip)
User Manual (.pdf)
  • Version: 5.0.8i
  • Supports: PowerPoint 97 to 2011 file formats
  • Requires: Windows XP, Vista or Windows 7 with PowerPoint 2007 or 2010 installed

Additional Resources

Previous Releases:

NOTE: Impatica OnCue users must use Impatica for PowerPoint v3.3.3 — see Impatica OnCue downloads.

Questions about Impatica for PowerPoint?

Email Impatica Customer Support or call:

  • In North America: (800) 548-3475
  • Outside North America: (613) 736-9982