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Legal Notice 

Copyright 2011 © Impatica Inc.  All rights reserved Impatica viaDock User’s Manual.  
 
The contents of this manual and associated Impatica software are the property of 
Impatica Inc. and are copyrighted.    
 
All specifications, claims, features, representations and/or comparisons provided are 
correct to the best knowledge of Impatica as of the date of publication, but are subject to 
change without notice.  
 
INFORMATION IS PROVIDED BY IMPATICA ON AN “AS IS “ BASIS, WITHOUT ANY 
OTHER WARRANTIES OR CONDITIONS, EXPRESSED OR IMPLIED, INCLUDING 
BUT NOT LIMITED TO, WARRANTIES OF MERCHANTABLE QUALITY, 
SATISFACTORY QUALITY, MERCHANTIBILITY OR FITNESS FOR A PARTICULAR 
PURPOSE.  IN NO EVENT SHALL IMPATICA INC. BE LIABLE FOR ANY LOSS OF 
REVENUE OR PROFIT OR ANY OTHER COMMERCIAL DAMAGE, INCLUDING BUT 
NOT LIMITED TO SPECIAL, INCIDENTAL, CONSEQUENTIAL OR OTHER DAMAGES.  
WE ARE ALSO NOT RESPONSIBLE FOR THE CLAIMS BY A THIRD PARTY.  OUR 
MAXIMUM AGGREGATE LIABILITY SHALL NOT EXCEED THIRTY DOLLARS 
CANADIAN ($30 CDN).  
 
PowerPoint, Windows, Windows Mobile, Pocket PC, ActiveSync and Exchange are either 
trademarks or registered trademarks of Microsoft Corporation. Java is a trademark of Sun 
Microsystems. The RIM and BlackBerry families of related marks, images and symbols 
are the exclusive properties of and trademarks or registered trademarks of Research In 
Motion Limited-used by permission. The Java Impatica for PowerPoint BlackBerry or 
Mobile Edition runtime is distributed in Eastridge Technology’s Jshrink format. Sony 
Ericsson is a trademark of Sony Ericsson Mobile Communications AB, Sony Corporation 
and Telefonaktiebolaget LM Ericsson. Bluetooth is a trademark of Bluetooth SIG, Inc. 
 
This software is based in part on the work of the Independent JPEG Group.  
 
This product includes software developed by the Apache Software Foundation 
(http://www.apache.org/). 
 
This equipment has been tested and found to comply with the limits for a Class A digital 
device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide 
reasonable protection against harmful interference when the equipment is operated in a 
commercial environment. This equipment generates, uses, and can radiate radio 
frequency energy and, if not installed and used in accordance with the instruction 
manual, may cause harmful interference to radio communications. Operation of this 
equipment in a residential area is likely to cause harmful interference in which case the 
user will be required to correct the interference at his or her own cost.  
 
Patent pending. 
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SECTION 1: About Impatica viaDock 

Thank you for selecting Impatica viaDock. 
 
Impatica viaDock allows you to access your BlackBerry from your computer, enabling you to use 
the comforts of your PC monitor and keyboard to operate your BlackBerry. Whether you wish to 
securely access enterprise applications from home, interact with your BlackBerry applications as 
PC applications, or simply want the comforts and conveniences of your large screen and 
keyboard, Impatica viaDock lets you get more from your BlackBerry. 

Impatica viaDock Features 
Impatica viaDock enables you to access your BlackBerry from your personal computer. With 
Impatica viaDock, you can easily:  

• Create a fully integrated environment—Use your PC and BlackBerry applications through 
one single system when at the office, home or anywhere you use a PC  

• Connect via Bluetooth or USB to your desktop or notebook PC  
• Share clipboards—Easily copy and paste text between your PC and BlackBerry 

applications  
• Quickly switch between BlackBerry applications—Use the application launcher or menu 

shortcuts to start using any application running on your BlackBerry  
• Dial and receive phone calls—Use on-screen phone controls to quickly make and answer 

phone calls, enable and disable hands-free talking and turn on and off mute  
• Know who is calling—Get instant notification of incoming calls while using viaDock, or 

through mini view when using other applications  
• Monitor your BlackBerry status—Always know your battery and radio signal strengths at 

a glance  

Impatica viaDock Tour 

Impatica viaDock can be operated in either normal view or mini view. The normal view displays 
the handheld screen, supports input from your PC keyboard and mouse and offers a variety of 
time-saving tools for operating your BlackBerry. The mini view is a small palette that can be kept 
in view while using other applications so that you may monitor your BlackBerry status and quickly 
place and receive phones calls. 

Normal View 

The normal view includes 5 areas as depicted below: 

1. Handheld screen area: Provides a live display of your BlackBerry screen. The size of 
this area can be changed by resizing the entire viaDock window, or by using View > 
Handheld Zoom. The quality of the handheld screen area can be set to either high quality 
or quick by using View > Handheld Quality.  

2. Phone controls: Includes answer and hang-up buttons, numeric keypad, hands-free and 
mute buttons, arrow buttons for navigating the BlackBerry and menu, select and escape 
buttons for controlling the BlackBerry. Display of these controls can be turned on off 
using the phone control button in the status bar, or by using View > Phone Controls.  
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3. Keyboard: Provides an on-screen keyboard for input to the BlackBerry, suitable for use 
with touch-screens (e.g., Tablet PCs). Display of the on-screen keyboard can be turned 
on and off using the keyboard button in the status bar, or by using View > Keyboard.  

4. Application Launcher: Includes shortcut icons for all of the applications currently 
running on the BlackBerry. Click any of the icons to quickly switch applications. Display of 
the application launcher can be turned on and off using the application launcher button in 
the status bar, or by using View > Application Launcher.  

5. Status Bar: Displays the BlackBerry's current battery strength, radio signal strength and 
incoming call notifications. Also provides buttons for showing and hiding other viaDock 
screen areas, turning on and off clipboard sharing and switching to mini view. Display of 
the status bar can be turned on and off using View > Status Bar.  

 

Mini View 

The mini view is a small window (shown below) that can be kept visible while using other PC 
applications.  

 

It provides you with ongoing status of your BlackBerry, including notification of incoming calls. 
Call answer and hang-up buttons are provided for quickly answering and placing calls. Hands-
free and mute buttons are also available to simplify controlling your BlackBerry. A quick dial field 
is provided, allowing you to place a call by simply entering a phone number then clicking the 
green call answer button. 
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To return to normal view, click the normal view button in the status bar. 

System Requirements 
 
Computer  

• Windows XP or Vista (Bluetooth enabled and/or BlackBerry Desktop Manager installed 
for USB connectivity); OR  

• Mac OS X 10.4 or higher with Bluetooth enabled.  

 
Handheld  

• BlackBerry smartphone with device software 4.2.2 or higher  

SECTION 2: Installing Impatica viaDock 

Installing Impatica viaDock requires the following two steps:  

• Install Impatica viaDock on your PC  
• Install Impatica Connector on your BlackBerry  

The following section will explain these steps in detail. 

Installing PC Software 
Install the Impatica viaDock application on your Windows or Mac OS X computer as follows:  
 
Windows  

1. Download the application installation file from: 
http://www.impatica.com/products/viadock/windows.html  

2. Once downloaded, double-click the file to install the application.  
3. Once it is installed, you will have both a desktop icon and a program entry for “Impatica 

viaDock”.  

 
Mac OS X  

1. Download the application installation file from: 
http://www.impatica.com/products/viadock/mac.html   

2. Once downloaded, the file will automatically mount the volume "Impatica viaDock". If this 
volume is not mounted, double-click the file Impatica-Virtual-Dock.dmg.  

3. Open the "Impatica viaDock" volume by double-clicking it or by selecting it in the Finder. 
Click and drag the "Impatica viaDock" icon to your hard drive (e.g., to the Applications 
folder) to complete the installation.  

4. If you wish, drag the Impatica viaDock icon to the Mac dock.  

 
You will be prompted to register your copy of Impatica viaDock the first time you run it.  
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Installing BlackBerry Software 

1. Install the Impatica Connector application on your BlackBerry smartphone using one of 
the following techniques: 
 
Over-the-air:  

1. To download the application directly to your BlackBerry, get this link using your 
BlackBerry Browser:  
http://www.impatica.com/bb/ 
 

2. Then select the “Download JAD from your BlackBerry” button in the Project your 
Screen section of the page.  
 

 
3. Follow the on-screen instructions. 

From your PC (Windows Only): 

1. Using a browser, navigate to: 
http://www.impatica.com/bb/ 
 

2. Then select the “Download ZIP from your PC” button in the Project your Screen 
section of the page and download the Impatica Connector zip file to your PC: 

 

3. Unzip ImpConnector.zip on your PC  
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4. Use the BlackBerry Desktop Manager Application Loader to select the ".alx" file 
and install the application on your BlackBerry  
 

Once you have installed the application, you must ensure that the necessary application 
settings and IT policies are set: 
 
Application Permissions: 
 
In order to use the Impatica viaDock, you must ensure that your application settings are 
properly configured by performing the following steps: 

1. Navigate to Options > Security Options > Application Permissions  
2. Select Impatica Connector from the list  
3. Select Edit Permissions, then either: 

 
(a) set all items under Connections and Interactions to Allow; OR 
 
(b) set the following specific permissions to Allow:  

� Under Connections:  
� USB (only if USB connection is required)  
� Bluetooth (only if Bluetooth connection is required)  
� Phone  

� Under Interactions:  
� Interprocess Communication or Cross Application 

Communication (4.6+ devices) 
� Keystroke Injection or Input Simulation (4.6+ devices) 
� Screen Capturing or Recording (4.6+ devices) 
� Security Timer Reset (for password protected devices only) 

IT Policies (only required if your BlackBerry is associated with a BES):  
 
For Bluetooth communication (under the Bluetooth policy section of the BES IT Policy 
dialog box):  

o Disable Serial Port Profile—Set to FALSE  
o Disable Bluetooth—Set to FALSE  
o Disable Pairing—Set to FALSE  

 
For USB communication: 

o Allow third party applications to use serial port—Set to TRUE  

For over-the-air installation: 

o Allow third party application downloads—Set to TRUE 

o Allow third party applications to use persistent store - set to True.  
This allows the software to store the Property Table file on the BlackBerry; 
 
 

Note: If your BlackBerry is associated with a BlackBerry Enterprise Server ("BES") or 
ever has been associated with a BES, you may not be able to change the application 
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permissions. In that case, an application control policy would need to be set on your BES 
and the Impatica Connector application would have to be pushed to the device with these 
settings set to Allow. 

Registering Impatica viaDock 
The first time you run Impatica viaDock, you will be asked to accept the terms of the license 
agreement and to enter your software registration information. Your registration information was 
provided to you via e-mail at the time that you received the Impatica viaDock software.  
 
To register your copy of Impatica viaDock:  

1. On your computer, double-click the Impatica viaDock application icon.  
2. Enter your name, organization and registration code in the fields provided. Ensure that 

the information is entered in exactly the same way as it appeared in the registration 
information provided to you by Impatica.  

If at any time you wish to change the software registration: 

1. Go to the Help menu and choose Register...  
2. Enter the new registration information in the fields provided.  

 
SECTION 3: Getting Started with Impatica viaDock 

In order to start using Impatica viaDock, you will need to complete the following steps:  

1. Launch Impatica viaDock on your PC  
2. Connect your BlackBerry to the viaDock software on your PC  
3. Start controlling your BlackBerry using your PC  

The following section will explain these steps in detail.  
 

Running Impatica viaDock 
To run Impatica viaDock, double-click the Impatica viaDock application icon on your computer.  

 

Note: The first time that you run Impatica viaDock, you will be prompted to accept the terms of the 
license agreement and enter your registration information. 
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Connecting to your BlackBerry 
Once the Impatica viaDock software is running on your computer, it will be waiting for a 
connection to your handheld. On Windows, Impatica viaDock can connect to your handheld either 
through USB or Bluetooth. On Mac OS X, connections can be made via Bluetooth. 
 
Bluetooth  

1. On your computer, ensure that the Impatica viaDock application is running.  
2. On the BlackBerry, use the Bluetooth screen to create a Bluetooth pairing with your 

computer. Note: You will be prompted to enter matching PIN numbers on your BlackBerry 
and on your computer.  

3. On the BlackBerry, launch the Impatica Connector application.  
4. From the list of Impatica enabled devices, choose your computer.  

 
USB (Available on Windows only)  

1. Ensure that the BlackBerry Desktop Manager application is installed on your Windows 
computer.  

2. On your Windows computer, ensure that the Impatica viaDock is running.  
3. Use a USB cable to plug your BlackBerry handheld into your Windows computer.  
4. On the BlackBerry, launch the Impatica Connector application.  
5. Select USB Connection from the list of Impatica enabled devices.  

Controlling your BlackBerry  
Using the Impatica viaDock, you can operate your BlackBerry through your keyboard, mouse and 
on-screen controls, as follows: 
 
Keyboard:  

• Use the alpha-numeric keys on your keyboard to type on your BlackBerry  
• Use the arrow keys on your keyboard in place of your BlackBerry trackball or trackwheel 

to navigate your BlackBerry  
• Use the following keyboard shortcuts to operate your BlackBerry:  

 

Key BlackBerry Control 

Letters and numbers Letters and numbers 

Arrows up, down, left right Trackball up, down, left, right 

Number pad (num lock off): 2, 4, 6, 8  Trackball down, left, right, up 

Tab  Menu 

Insert Menu 

` (~ without Shift) Select 

F9 Select 

5 on number pad (num lock off) Select 
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Esc Escape 

Home Dial 

End Hang-up 

Enter Enter 

Backspace Backspace 

Delete Delete 

Ctrl-C Copy 

Ctrl-X Cut 

Ctrl-V Paste 

 

On-screen controls:  

• Use the Impatica viaDock on-screen phone controls to start and end phone calls, turn on 
and off speaker phone and mute and to enter numbers on your BlackBerry;  

• Use the on-screen keyboard to type using a mouse; and  
• Use the application shortcuts or Go menu to quickly switch between BlackBerry 

applications.  

Mouse:  

• Click on the text below the handheld screen area of the Impatica viaDock to enter mouse 
control mode and start navigating your BlackBerry using your computer mouse.  

• Click the left mouse button to select and the right mouse button to escape on the 
BlackBerry.  

• To stop using your mouse to control your BlackBerry, press alt+z or click the scroll wheel.  

Scroll Wheel:  

• At any time, you can use your scroll wheel to navigate your BlackBerry.  
• Scroll your scroll wheel up and down to navigate your BlackBerry.  
• Click the scroll wheel to select (when not in mouse control mode).  
• Click the right mouse button to escape.  

Disconnecting from your BlackBerry  
When you wish to stop using the viaDock with your BlackBerry, terminate the connection using 
any of the following methods: 

• On the BlackBerry, select the Impatica Connector application. From the Stop Projecting 
dialog box that appears click OK; or  

• On your computer, close the Impatica viaDock application; or  
• If connected via USB, disconnect the cable. When you use this method, Impatica 

Connector will continue to run in the background. The next time you connect your 
BlackBerry to your PC with viaDock running, the connection should reestablish 
automatically. 
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SECTION 4: Switching BlackBerry Applications 

Impatica viaDock offers the following quick ways to switch between the applications that are 
currently running on your BlackBerry:  

• Using the application launcher  
• Using the Go menu  

The following section will explain both of these methods in detail. 

Using the Application Launcher 
Impatica viaDock provides an application launcher that enables you to quickly switch between all 
applications currently running on your BlackBerry, as depicted below:  

 

 

 

Application icons will automatically be added to the application launcher when the application 
starts on the BlackBerry. When an application on the BlackBerry closes, the icon will disappear 
from the application launcher.  
 
To switch applications, simply click the icon for the application you would like to use. To hide or 
show the application launcher, either click the application launcher button in the status bar or from 
the View menu, choose Application Launcher.  

 

Using the Go Menu 
Impatica viaDock includes a Go menu, which allows you to quickly switch between applications 
that are running on your BlackBerry. Applications are automatically added to and removed from 
the Go menu as they start and stop on the BlackBerry.  
 
To switch BlackBerry applications using the Go menu, simply click on the Go menu and choose 
the BlackBerry application you wish to use.  
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SECTION 5: Clipboard Sharing 

Impatica viaDock enables you to share your BlackBerry clipboard with your PC and vice-versa. 
This feature makes it easy to copy and paste between BlackBerry and PC applications.  

The following section will explain this feature in detail. 

Enabling the Clipboard Sharing Feature 
The ability to share clipboard contents between your BlackBerry and your PC can be turned on 
and off using either of the following methods:  

• Go the File menu and choose Share Clipboard; or  
• In the status bar, click the Share Clipboard button.  

Copying from your PC to your BlackBerry 
When the clipboard sharing feature is enabled, you can easily copy text from any PC application 
to any BlackBerry application using the following steps:  

1. On your computer, switch to the application that contains the text you would like to copy.  
2. Select the text, then choose copy (e.g., Edit > Copy or ctrl-C).  
3. Return to the Impatica viaDock application.  
4. Use Impatica viaDock to navigate your BlackBerry to where you would like to paste the 

text.  
5. Using viaDock, follow the normal BlackBerry procedure for paste (e.g. press Menu then 

Paste).  

Copying from your BlackBerry to your PC 
When the clipboard sharing feature is enabled, you can easily copy text from any BlackBerry 
application to any PC application using the following steps:  

1. Use Impatica viaDock to navigate to the BlackBerry application containing the text you 
would like to copy.  

2. Using viaDock, follow the normal BlackBerry procedure for selecting and copying.  
3. Switch to the computer application into which you would like to paste the text.  
4. Use your normal PC procedure for pasting into the PC application.  

SECTION 6: Troubleshooting Impatica viaDock 

Should you encounter any problems while using Impatica viaDock, please do the following:  

1. Review all of the topics in this Help system and follow any relevant instructions given.  
2. Check the Impatica Knowledgebase for an answer to your question.  
3. If you cannot find an answer to your question, please contact Impatica Customer 

Support.  

The following section will explain how to contact Impatica Customer Support.  
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Using the Impatica Knowledgebase 
For the most up-to-date questions and answers about Impatica Virtual Dock, please see the 
Impatica Knowledgebase: 
 
https://www.impaticize.com/impkb/categories/Impatica+viaDock/ 
 
From there, you can browse the most popular questions and answers or perform a keyword 
search to find the answer to your question.  

Contacting Impatica Customer Support 
If you encounter any difficulty using Impatica viaDock, or have any questions about the product, 
please contact Impatica Customer Support using one of the following methods.  
 
By E-mail:  

• Please e-mail Impatica Customer Support at support@impatica.com.  

By Phone:  

• In North America, call 1-800-548-3475 x:238 
• Outside of North America, call 613-736-9982 x:238 

Please note that Impatica Customer Support is open 8:30 am to 5:00 pm Eastern Time, Monday 
through Friday.  
 

 


